Wednesday, 22 July 2009

Misfiring. Anyone got any ideas?


I've just spent three hours and a 250-mile round trip trying to sort a misfire on my Wood Rotax racer. I went to see fellow racer, Anthony Brown of Co-Built, who had a full Rotax electrical system that he assures me was all good. We changed every component individually and methodically.
Coil, ignitor box, stator, pick, plug, HT cap... We disconnected the killswitch. We checked the carb and rubber. It misfires badly at half to full throttle. It starts and ticks over beautifully.
On the way home I thought it might be a kinked fuel line, but the plug is sooty black - which I think points to lots of fuel but a lack of spark. It also shoots the odd flame from the exhaust when it's misfiring which leads me to believe it's spark, not fuel. This bike has run well, it's not like I'e built it up and it's not set up.
The only thing we didn't change was the flywheel itself. We didn't check the valve clearances, but I adjusted them before my last
race and the problem occured the same both before and after that race.
Any ideas? Please... GI

16 comments:

Anonymous said...

sent u a email regards pete

Austin said...

ring my brother, after 3 or 4 years on the beach he's the king of solving things like this

Anonymous said...

have you checked your built hasnt slip a tooth and gone out of time?

Anonymous said...

belt i ment

Jorge Pullin said...

I've had good luck with Colortune, a glass see through spark plug.



Regards
Jorge

Diplomate said...

bloody hell gary - my cb200 special problem is obviously contageous - exactly the same symptoms as my twin. New coil, points, plugs, condenser etc etc etc etc !!!!%&??!"£??

Engine in shop to investigate timing slippage (very slack chain) so Anonymous' idea might be it !

Mark Erickson said...

I tend to agree with Anonymous, if it's not an electrical problem, and it's not a fuel problem, then it's likely a physical timing problem. Check the timing marks to see if the belt has skipped a notch. I'm not super familiar with the rotax single and I don't know how generous the tolerances are, but I'm suprised it didn't kiss a valve if this turns out to be the culprit.

To ease your spark worries, try to borrow a mechanic's timing tach (the type that you clip to a spark lead, digital readout is best. Sometimes they don't register less than 4 cylinders but an accurate reading isn't what's important in this experiment), don't pay attention to the actual numbers, but rev the engine to where it starts missing. If the tach starts registering 0 or other inconsistently low numbers mixed with the actual RPM's (ie. 6500>6510>1300>6300...)at this range then it means that it's skipping sparks, and I'd say your coil it likely to blame. It might be as simple as a grounding problem in that case.

Mark Erickson said...

also it should be noted that if the RPM readout remains consistent (+/- 300RPM) during the missfiring, then the issue is likely NOT an electrical one, but rather a fuel or timing issue

Anonymous said...

Have you had t' carb apart?
I take it it's not something daft like yer main jet falling out?

Anonymous said...

JUST GET RID NOW M8....... how much will buy it??

Anonymous said...

hey gary, dont have any answers, but i hope u get it sorted 4 sun.

Anonymous said...

could it be the answer is in the clues Dr Watson ?
Black sooty plug means running to rich . Full stop .(phone if u wanna talk mate)
Cu Sunday dude .#59

michael said...

Sounds like a rich misfire to me too. Have you checked float height and that the needle is seated properly?

By Hand and By Brain said...

yeah-heavy float...flames are from post ignition-
j-

By Hand and By Brain said...

well? what happened??

Diedre Greenshields said...

GI
Having checked the aforementioned usual suspects,
what about the choke?
What carburettor is it? a Dell'Orto is standard on a Woody I think? Do you use it for starting?
Crucially, Is it sticking maybe? If so pull the piston plunger out and grease it and the cable.

You could also visit your friendly vehicle (car) testing garage and have them stick their CO² probe up your end pipe. If you are man enough, you should not need any lubrication. These devises are normally used to test emissions and to check wether catalytic converts are doing their job.

Eitherway, once you have found the culprit, a Dyno session would be a very good idea. Not just for max BHP figures, but for crisper acceleration, better fuel management, and reliability.

'A well tuned under-dog can can run circles around an out of tune toroughbred'
my Nana always used to say.

x Dee